Almico's Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000002SpeedFanHardware supportpublic2004-06-06 21:432018-08-14 04:40
Reporterwhistler 
Assigned Toalfredo 
PrioritynormalSeveritymajorReproducibilityrandom
StatusclosedResolutionfixed 
PlatformintelOSxpOS Versionsp1
Product Version4.12 
Target VersionFixed in Version 
Summary0000002: speedfan dosnt work with shuttle xpc sb62g2
Descriptionfrom the mail:
i was just wondering if you will add support for Shuttle xpc sb62g2? i865g chipsett.
> the 5000 rpm chipsetfan is quite annoying :>

the problem is that speedfan will in 99.9% of the time report temp as -1 for
> all temps except hdd's. fans are detected as 0 rpm.
> tried with smartfan on and off in the bios also
Additional Informationintel p4 3.0c
wd raptor 36gb
wd caviar 200gb
1024 ram
radeon 9800 pro
soundblaster audigy 1
TagsNo tags attached.
Motherboard Modelmsi x370 gaming pro carbon
Video Card Modelpowercolor 9800 pro
Attached Files? file icon debug.nfo [^] (7,333 bytes) 2004-06-14 19:05
jpg file icon mbmbefore.jpg [^] (77,426 bytes) 2004-06-15 12:47


jpg file icon speedfaninthemiddle.jpg [^] (57,342 bytes) 2004-06-15 12:47


jpg file icon mbmafter.jpg [^] (36,000 bytes) 2004-06-15 12:47

- Relationships

-  Notes
(0000021)
whistler (reporter)
2004-06-14 17:38

ive been testing a bit now.
just tried to start speedfan the other day and it detected the correct sensors and i had no problems adjusting the cpufan. :D
but it does have problems adjusting the chipsetfan. if i set % to 2% its still on full rpm (5000). when i set it to 1% i drops to 0001301:0004300.. still noisy.
BUT i had to check if speedfan could adjust the third fanconnector, and so i turn off the shuttle and connect an intel fan to the third fanconnector and boot up.
i start speedfan but i detects only -1 on all temps. i close speedfan and restart it. it detects 0 sensors.
i restart speedfan again. 0 sensors..
restart again
and again
..
..
then it detects the hd's. and temps as 127 on all three of them. weird.
i wont detect the correct sensors. :(
so now i use smartfan in the bios again. it has no problem adjusting the intel fan at fanconnecter 3.
thought maybe this would help.
(0000033)
whistler (reporter)
2004-06-14 22:48

any new info ?
(0000034)
almico (administrator)
2004-06-15 02:24

I can't understand which is the reason why SpeedFan sometimes is able to find sensors and some others not.
The question is: is there any way for you to be sure that SpeedFan will detect your sensors for sure? Which one?
(0000035)
whistler (reporter)
2004-06-15 12:12

its totally random when it finds the correct sensors.
just tried speedfan again now. it found only the hdd temps.
I/O properly initialized
!!!Exception in reading CPU INFO at startup (2)!!!
Linked ISA BUS at $0290
Linked Intel 82801EB ICH5 SMBUS at $0500
Scanning ISA BUS at $0290...
SuperIO Chip=IT8712F
Scanning Intel SMBus at $0500...
SMBus msg : 12:08:50.421 Unsuccessful WRITEQUICK $00 to $44
SMBus msg : 12:08:50.421 Unsuccessful WRITEQUICK $00 to $44
SMART Enabled for drive 0
Found WDC WD360GD-00FNA0 (37,0GB)
SMART Enabled for drive 1
Found WDC WD2000JD-00FYB0 (200,0GB)
End of detection

when i start speedfan the cpu fan will go to 100%. even though speedfan doesnt detect the fans or the tempsensor. it overrides the smartfan in the bios. i have to restart the shuttle for smartfan to work again. :|
(0000036)
whistler (reporter)
2004-06-15 12:48

check out the pics. something weird happens when i start speedfan. :O
(0000037)
alfredo (manager)
2004-06-15 12:54

So: if you just run MBM, everything shows up properly an works fine. If you run SF it looks like that, after detection at startup, the sensor chip disappears. Right?
Try to start SpeedFan with the /NOTIMER command line switch and try to send me a SEND REPORT.
(0000038)
whistler (reporter)
2004-06-15 14:33

Now, the final check is: try to run SpeedFan only with the following command line option:

/NOSMBSCAN



yeah baby ;D it works! :D
tried to start speedfan several times now and it works fine every time :D great :)
(0000039)
alfredo (manager)
2004-06-15 14:54

So, the fix is to use the

/NOSMBSCAN

command line switch.
There must be something that collides on the SMBus and never releases it. I'm afraid it's the SuperIO chip itself. Some kind of interrupt might have been enabled by the BIOS and SpeedFan, like almost every other hardware monitoring software out there, can't handle them.
Thank you for your reports and time :-)

- Issue History
Date Modified Username Field Change
2004-06-06 21:43 whistler New Issue
2004-06-06 21:43 whistler Video Card Model => powercolor 9800 pro
2004-06-14 17:38 whistler Note Added: 0000021
2004-06-14 19:05 whistler File Added: debug.nfo
2004-06-14 22:48 whistler Note Added: 0000033
2004-06-15 02:24 almico Note Added: 0000034
2004-06-15 12:12 whistler Note Added: 0000035
2004-06-15 12:47 whistler File Added: mbmbefore.jpg
2004-06-15 12:47 whistler File Added: speedfaninthemiddle.jpg
2004-06-15 12:47 whistler File Added: mbmafter.jpg
2004-06-15 12:48 whistler Note Added: 0000036
2004-06-15 12:54 alfredo Note Added: 0000037
2004-06-15 14:25 alfredo Status assigned => acknowledged
2004-06-15 14:33 whistler Note Added: 0000038
2004-06-15 14:51 alfredo Severity feature => major
2004-06-15 14:51 alfredo Reproducibility always => random
2004-06-15 14:51 alfredo Category Fan control => Hardware support
2004-06-15 14:54 alfredo Status acknowledged => resolved
2004-06-15 14:54 alfredo Resolution open => fixed
2004-06-15 14:54 alfredo Note Added: 0000039
2004-06-24 11:42 alfredo Status resolved => closed
2018-08-14 04:38 fusiondog8 Motherboard Model => msi x370 gaming pro carbon


Copyright © 2000 - 2019 MantisBT Team
Time: 0.1369 seconds.
memory usage: 8,135 KB
Powered by Mantis Bugtracker