Almico's Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000003SpeedFanOtherpublic2004-06-11 23:052018-08-14 04:40
ReporterLoustic 
Assigned Toalfredo 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionreopened 
PlatformPCOSWindowsOS VersionXP SP1
Product Version4.12 
Target VersionFixed in Version 
Summary0000003: Speedfan change my monitor settings
DescriptionSpeedfan change my monitor settings, reducing the visible surface.
Steps To ReproduceLaunch speedfan
Additional Informationworked fine under 4.09
TagsNo tags attached.
Motherboard Modelmsi x370 gaming pro carbon
Video Card ModelNvidia GeForce 3
Attached Files? file icon debug.nfo [^] (36,991 bytes) 2004-06-11 23:05
txt file icon DxDiag.txt [^] (46,315 bytes) 2004-06-12 11:04 [Show Content]

- Relationships
has duplicate 0000007closedalfredo screen crash 
has duplicate 0000008closedalfredo Program initialization crashes internal monitor settings 

-  Notes
(0000003)
alfredo (manager)
2004-06-12 09:49

I expected something similar, but this seems to happen only on very very few computers. I assume the resolution change takes place during the initial sensor detection phase.
Possible steps to avoid this might be:
1) install the latest nVidia drivers from nVidia web site
2) use the command line switch /NONVIDIAI2C (but any available sensor on the video card will no longer be detected and used).
If you're using any other software that talks to the video card, such as TVTOOL or some manufacturer specific software, it would be nice for me to know.
If you could send me a SEND REPORT (please inform me when you will do so), I will check to see if this might be due to some detection routine that might be writing something in some registers on your video card.
(0000004)
Loustic (reporter)
2004-06-12 11:37

1) Well, drivers are not that old.
2) /NONVIDIAI2C works fine. I have however no sensor on that card (have I ?)
3) I only use Nview, packed with the drivers.

A)I uploaded the dxdiag logs, see if that help you
B)I also have now "CPU Usage". It also work fine in 4.09
C)I'd like to send a report, bug my computer freezes when trying to scan PCI ...
(0000005)
alfredo (manager)
2004-06-12 11:50

There is a special DEBUG procedure. You can find it explained in the help file. If you follow those steps I might fix this issue with your computer once and for ever, otherwise we might consider it fixed by the /NONVIDIAI2C.
The fact is that there seems to be something that conflicts with SpeedFan when it reads the SMBus. I'm telling you this because a problem during SEND REPORT can only be caused by READs: sending a report does not write anything. Since you're telling me that it freezes while SCANNING PCI (very odd indeed), I would really like to further investigate.
You might try the following command line options:
1) /NOPCISCAN : this will avoid detection of ANY SMBus and you will be able to see your sensors only if they are on the ISA BUS
2) /NOSMBSCAN : this will allow the PCI SCAN, but will end up with very little as the relevant SMBus devices won't be scanned.
By trying a SEND REPORT with /NOPCISCAN we can try to isolate the reason for the hang.
On the other hand: if a SEND REPORT with /NOSMBSCAN works fine, then the problem is not related with PCI SCANNING (I've never seen any problem related to PCI scanning).
(0000006)
Loustic (reporter)
2004-06-12 12:15

1) /NOPCISCAN : works fine, report was sent
2) /NOSMBSCAN : crashed
(0000007)
alfredo (manager)
2004-06-12 12:26

I just sent to you a beta :-)
(0000008)
Loustic (reporter)
2004-06-12 12:36

I just send you a report :)
(0000041)
alfredo (manager)
2004-06-17 00:24

The /NONVIDIAI2C command line switch fixes the issue. A fortcoming release will hopefully no longer need this switch
(0000045)
alfredo (manager)
2004-06-17 10:57

Version 4.13 will improve nVidia Video Card support, remove some checks for odd hardware devices and completely remove nVidia Video Card I2C scanning in SEND REPORT.
This way there is no known way to hurt the monitor via SpeedFan.

- Issue History
Date Modified Username Field Change
2004-06-11 23:05 Loustic New Issue
2004-06-11 23:05 Loustic File Added: debug.nfo
2004-06-11 23:05 Loustic Video Card Model => Nvidia GeForce 3
2004-06-12 09:49 alfredo Note Added: 0000003
2004-06-12 11:04 Loustic File Added: DxDiag.txt
2004-06-12 11:37 Loustic Note Added: 0000004
2004-06-12 11:38 alfredo Status assigned => acknowledged
2004-06-12 11:50 alfredo Note Added: 0000005
2004-06-12 12:15 Loustic Note Added: 0000006
2004-06-12 12:26 alfredo Note Added: 0000007
2004-06-12 12:36 Loustic Note Added: 0000008
2004-06-14 08:58 alfredo Relationship added has duplicate 0000007
2004-06-14 14:49 alfredo Relationship added has duplicate 0000008
2004-06-17 00:24 alfredo Status acknowledged => resolved
2004-06-17 00:24 alfredo Resolution open => fixed
2004-06-17 00:24 alfredo Note Added: 0000041
2004-06-17 10:57 alfredo Status resolved => feedback
2004-06-17 10:57 alfredo Resolution fixed => reopened
2004-06-17 10:57 alfredo Status feedback => closed
2004-06-17 10:57 alfredo Note Added: 0000045
2018-08-14 04:38 fusiondog8 Motherboard Model => msi x370 gaming pro carbon


Copyright © 2000 - 2019 MantisBT Team
Time: 0.1482 seconds.
memory usage: 8,136 KB
Powered by Mantis Bugtracker